Maintenance on the Ivido PGO
Scheduled for April 12, 2022 at 5:00 PM – 6:00 PM
Affects
PGO Ivido (app.ivido.nl)
Under maintenance from 5:00 PM to 6:00 PM
Completed
April 12, 2022 at 6:00 PMCompleted
April 12, 2022 at 6:00 PMMaintenance has completed successfully
In progress
April 12, 2022 at 5:00 PMIn progress
April 12, 2022 at 5:00 PMMaintenance is now in progress
Planned
April 12, 2022 at 5:00 PMPlanned
April 12, 2022 at 5:00 PMWe are planning for a scheduled maintenance during that time.