Ivido - Ivido website down – Incident details

All systems operational

Ivido website down

Resolved
Operational
Started over 1 year agoLasted about 3 hours

Affected

Website (ivido.nl)

Operational from 8:26 AM to 11:46 AM

Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Identified
    Identified

    We are continuing to work on a fix for this incident.